Objective
In this challenge, we're getting started with conditional statements. Check out the Tutorial tab for learning materials and an instructional video!
Task
Given an integer, n, perform the following conditional actions:
If is odd, print Weird
If is even and in the inclusive range of 2 to 5, print Not Weird
If is even and in the inclusive range of 6 to 20, print Weird
If is even and greater than 20, print Not Weird
Complete the stub code provided in your editor to print whether or not n is weird.
Input Format
A single line containing a positive integer, n.
Constraints
1 <= n <= 100
Output Format
Print Weird if the number is weird; otherwise, print Not Weird.
Sample Input 0
3
Sample Output 0
Weird
Sample Input 1
24
Sample Output 1
Not Weird
Explanation
Sample Case 0:
is odd and odd numbers are weird, so we print Weird.
Sample Case 1:
and is even, so it isn't weird. Thus, we print Not Weird.
import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;
public class Solution {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int n = scan.nextInt();
scan.close();
String ans = "";
// if 'n' is NOT evenly divisible by 2 (i.e.: n is odd)
if (n % 2 == 1)
ans = "Weird";
// Complete the code
else if (n >= 2 && n <= 5)
ans = "Not Weird";
else if (n >= 6 && n <= 20)
ans = "Weird";
else if (n > 20)
ans = "Not Weird";
System.out.println(ans);
}
}
'IT > Programming' 카테고리의 다른 글
[HackerRank] Day 5: Loops (0) | 2023.04.17 |
---|---|
[HackerRank] Day 4: Class vs. Instance (0) | 2023.04.17 |
[HackerRank] Day 2: Operators (0) | 2023.04.17 |
[HackerRank] Day 1: Data Types (0) | 2023.04.17 |
[HackerRank] Day 0: Hello, World. (0) | 2023.04.17 |